Press "Enter" to skip to content

Настройка Wi-Fi Mikrotik CAPsMAN

Задача: настроить бесшовный роуминг wi-fi на этаже административного здания.
Имеем в наличии:
1. Коммутатор/роутер. Например вот такой — CRS328-24P-4S+, он уже с PoE — 1шт

2. Точки доступа. Например вот такие — RBcAPGi-5acD2nD, 5шт

Настраиваем маршрутизатор.

Удаляем дефолтную конфигурацию.

Обновляем прошивку (последняя long-term).

Создаем два бриджа — в первый помещаем порты, к которым будем подключать точки, ко второму — которые будут смотреть в сеть конторы.

Назначаем им соответствующие адреса:

Прописываем маршрут по умолчанию:

И DNS-сервера:

Добавляем пул адресов для DHCP:

И настраиваем DHCP-сервер для bridge1:

Адреса точек доступа будем назначать вручную, поэтому пул начинаем не с начала подсети.

DHCP Server — Networks:

В System — Identity задаём идентификатор устройства:

Далее необходимо убедиться что присутствует пакет wireless (на старых прошивках может не быть):

Переходим в CAPsMAN:

Далее там же вкладка Channels — «+»:

Аналогично для 5 GHz:

Для настройки пароля для подключения к нашей сети переходим на вкладку Security Cfg.:

Далее режим обработки данных Datapaths:

  1. В поле Name оставляем имя без изменения datapath1.
  2. В списке Bridge выберите бридж интерфейс.
  3. В поле Local Forwarding ничего не указываем, чтобы наша система работала в режиме Manager Forwarding Mode.
    В режиме Local Forwarding Mode обработка и перенаправление данных клиентов осуществляется непосредственно на Wi-Fi точках доступа, а не на роутере.
    В режиме Manager Forwarding Mode все данные клиентов передаются на роутер, где производится их обработка. В этом случае CAPsMAN полностью контролирует перенаправление данных, включая обмен данными между клиентами. Этот режим  создает больше нагрузку на сеть и роутер.
  4. Поставьте галочку Client To Client Forwarding, чтобы разрешить клиентам обмениваться данными друг с другом.

Далее создаем конфигурацию для частоты 2,4ГГц:

При необходимости проделываем то же самое для 5 GHz:

Далее необходимо настроить параметры развертывания Provisioning для частоты 2,4ГГц:

  1. Откройте вкладку Provisioning.
  2. Нажмите синий плюсик.
  3. В списке Hw. Supported Modes выберите стандарты gn. Это означает, что указанная конфигурация будет применяться для устройств с поддержкой g и n стандартов, т.е. работающих на частоте 2,4ГГц.
  4. В списке Action выберите create dynamic enabled, чтобы в контроллере CAPsMAN автоматически создавались интерфейсы подключаемых точек.
  5. В списке Master Configuration выберите конфигурацию для 2,4ГГц, т.е. cfg2.
  6. Нажмите OK.

Добавьте второе правило развертывания для частоты 5ГГц.

  1. Нажмите синий плюсик.
  2. В списке Hw. Supported Modes выберите стандарты an. Это означает, что указанная конфигурация будет применяться для устройств поддерживающих a и n стандарты, т.е. работающих на 5ГГц.
  3. В списке Action выберите create enabled.
  4. В списке Master Configuration выберите конфигурацию для 5ГГц, т.е. cfg5.
  5. Нажмите OK.

Добавляем правила Firewall в роутере

В последних прошивках в конфигурации по умолчанию Firewall блокирует трафик CAPsMAN. Поэтому нужно добавить в Firewall правила, которые разрешат прохождение трафика CAPsMAN.

Откройте в роутере меню New Terminal и выполните следующие команды:

# Добавляем в фаервол правило разблокировки трафика CAPsMAN
/ip firewall filter add action=accept chain=input dst-address-type=local src-address-type=local comment=»UnblockCapsman» disabled=no

# Перемещаем в фаерволе правило UnblockCapsman вверх выше остальных правил
/ip firewall filter move [find comment=»UnblockCapsman»] 1

В настройках менеджера CAPsMAN может быть ограничена его работа на определенных интерфейсах. Нужно включить CAPsMAN на всех интерфейсах сети, и запретить на любом интерфейсе, на котором вы не хотите слушать CAPsMAN

Добавляем Wi-Fi точку в контроллер:

Удаляем дефолтную конфигурацию с точки доступа. Ждем перезагрузки.

Далее в Quick Set:

Точка перезагрузится ещё раз.

Меняем интерфейс назначенному ранее адресу с ether1 на bridge1:

Добавляем правила Firewall в точке доступа

В последних прошивках в конфигурации по умолчанию Firewall блокирует трафик CAPsMAN. Поэтому нужно добавить в Firewall правила, которые разрешат прохождение трафика CAPsMAN.

Откройте в точке доступа меню New Terminal и выполните следующие команды:

# Добавляем в фаервол правило разблокировки трафика CAPsMAN
/ip firewall filter add action=accept chain=input dst-address-type=local src-address-type=local comment=»UnblockCapsman» disabled=no

# Перемещаем в фаерволе правило UnblockCapsman вверх выше остальных правил
/ip firewall filter move [find comment=»UnblockCapsman»] 1

Далее настраиваем wlan интерфейсы. В меню Wireless, на вкладке Interfaces нажмите кнопку CAP.

После этого Wi-Fi точка автоматически получит настройки и запустит интерфейсы wlan1 на 2,4ГГц и wlan2 на 5ГГц.

Теперь откройте настройки роутера, и перейдите в меню CAPsMAN на вкладку Interfaces. Здесь автоматически создались два новых интерфейса точки доступа cap1 и cap2.

Изменяем идентификатор роутера и точки доступа

Чтобы было удобно отслеживать, к какому устройству подключился клиент, переименуем их идентификаторы.

  1. В настройках роутера перейдите в меню CAPsMAN на вкладку Remote CAP.
  2. Откройте двойным щелчком мыши необходимое устройство.
  3. Нажмите кнопку Set Identity.
  4. В поле Identity укажите необходимое имя.
  5. Нажмите кнопку Set Identity.
  6. Нажмите кнопку OK.

Проделываем аналогичные действия для оставшихся точек доступа.

Настройка сбрасывания клиентов с плохим уровнем сигнала

Бывают ситуации, когда клиентское устройство подключается к одной Wi-Fi точке и никак не хочет переключаться на другую, даже если стоять возле нее. В этом случае можно настроить принудительное сбрасывание клиента с точки в зависимости от уровня сигнала. Однако при таком сбросе, если вы разговариваете по Skype или Viber, произойдет завершение звонка и нужно будет перезвонить.

  1. В настройках роутера откройте меню CAPsMAN и перейдите на вкладку Access List.
  2. Нажмите синий плюс.
  3. Укажите уровень, при котором сбрасывать клиента с Wi-Fi точки. На картинке видно, что клиент с уровнем сигнала —85 dBm и хуже (-120 dBm), будет сбрасываться с точки. Обратите внимание, что необходимый уровень сбрасывания прописывается справа! Поиграйтесь с уровнями от -75 до -85 (т.е. -120..-75, -120..-80, -120..-85), чтобы выбрать оптимальный для вас.
  4. В списке Action выберите reject.
  5. Нажмите кнопку OK.

 

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

8 + 2 =